Nowhere Development Status
Current Version: Alpha 91
Release: TBA
Last tweet: 724 days ago

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

The game doesn't run (Ubuntu and Windows 7 + nVidia Quadro FX 1000M + Thinkpad W520)

edited August 2014 in Support

Hello Nowherians! I met Leonard and Sylvia today at GDC and it was sad that I couldn't talk about the game because I couldn't make it run yet. I already ditched some errors, but these ones I just don't have enough knowledge to solve them.

When I run:

$ ./run-nowhere

it returns this:

No handlers could be found for logger "pyopengl"
./run-nowhere: line 11: 30538 Segmentation fault (core dumped) ./bin/pypy -m nowhere $*

I'm on a Thinkpad W520 with the Nvidia Optimus technology. I have Bumblebee installed so I can launch the game with the dedicated card, but it doesn't make a difference, the output is the same.

uname -a shows:
3.13.0-32-generic #57-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux



  • Hey Leonard, here's my glxinfo and the debuglog.txt

    Thanks a lot!!

  • edited August 2014

    I tried on Windows 7 (64bits) and it doesn't run either. Probably it's because the graphics card: Nvidia Quadro FX 1000M

    Running nowhere.bat displays this


    I want to play it T_T


  • edited August 2014

    Hi kednar,

    I'm sorry you're having problems getting the game to run.

    Your first debuglog indicates that you're running a GL 3.0 driver. NOWHERE needs at least GL 3.2 and Shadermodel 1.50 to run. The second debuglog indicates that the game is running on an internal Intel card (also < GL 3.2) instead of the nvidia one you mentioned.

    In the first case you'll need to get newer drivers (Intel MESA supports 3.3 now), in the second case you'll need to figure out how to tell Optimus to use your Quadro FX and/or update your drivers.

    I recently installed Ubuntu 14.04 on our Intel HD based laptop and noticed they're shipping the newest drivers with the distro now.

  • Alles klar. I'll try to update everything and report back :)


  • edited August 2014

    OK! I got it running on Windows assigning the Nvidia card to run the python executable. It works, and it's amazing :_D

    On Linux I modified the launcher to do the same. In case there's another Optimus user with Bumblebee out there, I just added "optirun" to the last line of the "run-nowhere" script:

    optirun ./bin/pypy -m nowhere $*

    But it crashes before generating the structure, right after displaying "Loading". It says:

    TypeError: 'NoneType' object is not callable

    The new debuglog.txt

    I'm playing on Windows, but I'd really love to run it on Linux, which is my main OS and where this game is being developed :)


  • Hey @kednar :).

    You got it running on Windows, very good.
    We will fix the Linux problem with the next alpha version in ~2 weeks.

  • Well, I replaced Bumblebee with the new proprietary Nvidia drivers (and nvidia-prime) and it runs!
    In case anyone uses the Optimus technology, follow this steps.

Sign In or Register to comment.