Nowhere Development Status
Current Version: Alpha 91
Release: TBA
Last tweet: 73 days ago
Funding goal: 37%
Founders: 1621

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Alpha 91 Not Starting

I tried to run nowhere.bat in windows and all I get is a console with an error "Could not create GL context". Here is what was in the log:

INFO:beige.config:Loading game info from C:\Users\Momo\Desktop\nowhere-a91-win32\data\game.json
INFO:beige.config:Loading config from C:\Users\Momo\AppData\Roaming\duangle\nowhere\settings.json
INFO:liminal.model:Loading C:\Users\Momo\Desktop\nowhere-a91-win32\data\main.project...
INFO:liminal.model:Loaded project nowhere
INFO:beige.system:GL Vendor: Intel
INFO:beige.system:GL Renderer: Intel(R) HD Graphics 3000
INFO:beige.system:GL Version: 3.1.0 - Build 9.17.10.3347
INFO:beige.system:GL Shadermodel: 1.40 - Intel Build 9.17.10.3347
INFO:beige.system:GL Context Major Version: 2
INFO:beige.system:GL Context Minor Version: 1
INFO:beige.system:GL_MAJOR_VERSION: 3
INFO:beige.system:GL_MINOR_VERSION: 1
INFO:beige.system:MAX_DRAW_BUFFERS: 8
INFO:beige.system:MAX_ELEMENTS_INDICES: 1200
INFO:beige.system:MAX_ELEMENTS_VERTICES: 1200
INFO:beige.system:MAX_COLOR_TEXTURE_SAMPLES: 4
INFO:beige.system:MAX_DEPTH_TEXTURE_SAMPLES: 4
INFO:beige.system:MAX_TEXTURE_IMAGE_UNITS: 16
INFO:beige.system:MAX_TEXTURE_SIZE: 8192
INFO:beige.system:MAX_RECTANGLE_TEXTURE_SIZE: 8192
INFO:beige.system:MAX_3D_TEXTURE_SIZE: 2048
INFO:beige.system:MAX_UNIFORM_BUFFER_BINDINGS: 24
INFO:beige.system:MAX_COMBINED_TEXTURE_IMAGE_UNITS: 16
INFO:beige.system:Initializing SDL subsystem...
INFO:beige.system:Setting GL context version to 3.2
INFO:beige.system:Creating window (1280x800 x:0 y:0)
INFO:beige.system:Video Quality: 4
INFO:beige.system:Creating context...

Can anyone please help?

Comments

  • Hi & welcome @WhYNoT ,

    try to get a new graphics driver for your intel card. You will need Opengl 3.2 and it seems you've only got 3.1.

    Hope I could help!
    I also added/verified you as a founder to the forum. :)

    Best,
    Sylvia

  • Hi, I'm quite familiar with graphics drivers. Indeed, I updated it by getting the drivers for Intel HD 3000 under windows and I still get the error. I also tried running the game on Linux Mint, and nothing happens when I open the script. I tried updating the the driver on linux but the deb file won't run because of "unsatisfiable depends" with libglib. I suspect the issue is the integrated graphics itself so I tried putting one of my older graphics card in my PC, but my PSU isn't powerful enough.
    I tried it on another PC with dedicated graphics (GTX 260), and it ran fine. The game looks beautiful btw!
    I will try to run the other alphas to see if that makes a difference. I'll also try to switch out the PSU.

    Thanks for the quick response and for adding me as founder :)

  • I installed Fedora because apparently it supports the Intel drivers with OpenGL 3.2 but now I get this error:

    [momo@localhost ~]$ '/home/momo/Desktop/nowhere-a91-linux64/run-nowhere'
    ./bin/pypy: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

  • edited June 2014

    Tested on Ubuntu. Bottom line is that OpenGL 3.2 should work on HD 3000 but it doesn't on Windows. Tried to run on Linux but I get other errors. This is super frustrating.

  • I have alpha 75 working by using --glarb 3.0. It looks great! Would still like to see the new alpha though...

    Any chance the next alpha will bring back OpenGL compatiblility before 3.2?

  • I've actually also been having trouble with Alpha 91. In fact I've not been able to play it yet. Once I press play, it lags severely and the terrain never loads. I'm fine with it though, I love playing with Alpha 75 ;)

  • Yeah, but having tested alpha 91 on my other PC, I know that one is pretty awesome. But considering yours is just lag, you can probably run it with --video-quality 0. I have tried most of the other alphas and none seem to work :/

  • edited June 2014

    Every time I try to set the video quality to 0, it doesn't work. Also, it's not just lag, the actual objects don't render at all.

  • I think it was just my computer. I got a new computer 2 weeks ago and it works perfectly :D

Sign In or Register to comment.